Program för PC

Print spooler stoppad.

2011-08-30 22:11 #0 av: Isa56

Hej allesammans. (Hoppas det blev rätt grupp jag la det i)

Nu behöver jag tips och tricks för att få igång utskriftsbufferten.

Jag har en Acer dator med Vista som är ca 2,5 år gammal. Den gamle skrivaren är en Lexmark X1150. Jo, jag vet lexnark och Vista är inte riktigt kompatibla med varandra, men det har fungerat bra i 2 år. Nu börjar skrivaren att krångla, så jag bestämde mig och köpte en ny skrivare, en Canon PIXMA MG5150.

Installerar den efter konstens alla regler, men glömmer att lägga till skrivare i datorn. Sen avinstallerar jag Lexmarken.... Kommer på att jag inte lagt till skrivaren och går in i kontrollpanelen för att göra det. Upptäcker lite förvånad att alla skrivare är borta. Klickar på "lägg till skrivare" och får upp en liten ruta som talar om att utskriftsbufferten är stoppad.

Jaha, sen har jag nog varit överallt i datorn och letat, kom underfund med att det är "Print spooler" som är stoppad. Har googlat och provat på en del tips. Jag har varit in i aktivitetshanteran, nobben. Har skrivit in spoolern i kommandotolken och högerklickat och kört som administratör (jag har två konton på datorn, ett vanligt användarkonto för dagligdags och adm. för ändringar) Har provat att skriva service.msc i kommandotolken och scannat datorn. Har provat microsofts "Fix it" Får reda på att det rättat till en del fel men problemet kvarstår.

Har kollat att RPC och DCOM är inställda på automatik och startade.

Har avinstallerat Canon och installerat igen... Går inte för utskriftsbufferten är stoppad.Förvånad

Försökte installera Lexmarken igen. Får upp en ruta med det ovanliga "utskriftsbufferten är stoppad" men under det får jag en fråga om jag vill starta den? glad klickar jag ja.... Sen händer inget mer. Print spooler fortsätter sin dvala.

Nu undrar jag om någon här inne har någon ljus ide. Jo uppdatera till Windows 7 kanske. Men nog ska det väl gå att väcka liv i utskriftsbufferten igen, väl?

Mina datorkunskaper är lite punktvisa, en del kan jag en del fattar jag inget av.

Tack på förhand

Isa

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-08-31 09:11 #1 av: Kaj

Gå till startknappens sökruta och skriv "services.msc" (ser att du redan gjort det iofs).

Starta det programmet och du får upp alla tjänster. Sök upp "Print Spooler" och kolla status på den. Ifall den är nedstängd sätt den till startmetod "Automatisk"

Om den trots det inte vill starta så måste du kolla i händelseloggen vad som orsakar problemet med den tjänsten.

Gå till startknappens sökruta och skriv "händelselogg" och starta "Visa händelseloggar"
Ev problem bör du se under Windows loggar (Program, Säkerhet, och system) Även installation kan vara ett läge.

Sist kan du försöka göra en återställning tills innanss då du började med att installera din nya skrivare. Därefter avinstallera Lexmarken (Starta om) och sedan installera

Printer spoolern ligger i C:\WINDOWS\System32\spoolsv.exe

Anmäl
2011-08-31 11:46 #2 av: Isa56

Tack Skrattande

Tyvärr har det inte löst problemet. Återställning körd till första återställningspunkten (en månad tillbaka) hjälper inte. Försökt att återinstallera Lexmarken från skivan, går inte. Båda skrivarna är avinstallerade.

Loggen sa mig ingenting, mer än att jag har några fel rapporterade.

I "tjänster" högerklickar jag på print spoolern och klickar egenskaper, ser att den är beroende av en tjänst som heter "LexBce server", den tjänsten står på automatik, men går inte att starta för filen kan inte hittas felkod 2. Stoppade den tjänsten och försökte starta Spoolern, men får då upp att den är markerad för borttagning?

Den tjänsten LexBce server borde väl kunna kopplas ifrån Spoolern,(Den finns ju inte) men var gör jag det. Jag tror den filen har med Lexmarken att göra (googlade på det och den tillhör Lexmarken).

Isa

 

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-08-31 20:26 #3 av: Zepp

Stratar du om datorn mellan vaje av o på-instalation?

Ljuva dröm att som en svensk se ut, att få lära sig att veta hut.

Anmäl
2011-08-31 20:29 #4 av: Isa56

Nja, det har jag nog inte gjort alltid. Ska prova med det också.

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-08-31 20:30 #5 av: Zepp

För en del grejer försvinner inte fören man startar om!

Ljuva dröm att som en svensk se ut, att få lära sig att veta hut.

Anmäl
2011-08-31 20:33 #6 av: Isa56

Ja, ska genast prova det också. Skrattande

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-09-01 10:15 #7 av: Isa56

Det enda som hänt är att "Print spooler" nu försvunnit från mappen "tjänster" och Canon ligger under diskar i "enhetshanteraren".

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-09-01 14:41 #8 av: Zepp

Fungerar det då?

Annars avinstalera.. starta om och instalera igen.

Starta alltid om mellan av och på-instalationer.

Ljuva dröm att som en svensk se ut, att få lära sig att veta hut.

Anmäl
2011-09-01 18:44 #9 av: Isa56

Nej Print spoolern är borta. Just nu kör jag felsäkert läge. Har avinstallerat och startat om, gick inte att installera. Stängt ner och nu startad i felsäkert läge.

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-10-14 22:59 #10 av: Isa56

Lite updatering. Print spoolern är fortfarande i dvala.

Har fått en spooler fil bränd på skiva från en annan vista dator. Men där är också en Lexmark installerad. Har kopierat och lagt den i mappen "sys32". När jag försöker starta den som admin så bara blinkar en ruta till och inget mer händer.

Spoolern finns inte i mappen "tjänster" "RPC" och den andra är startad. Hur får jag in den i mappen "tjänster"?

När jag går in i spools mappen finns där en del mappar, i en ( heter x32-x86 eller liknande) finns där en massa "cabinettfiler" som börjar på lxd...... Vad är de för filer? Tillhör de Lexmarken och ska raderas?

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-10-15 20:05 #11 av: Micro08

 

 

Här har du en Fix-it lösning (öppnas i nytt fönster) från Windows som är väldigt bra att använda när allt verkar kört. Det är ett diagnostikprogram (.exe) som du kör och förhoppningvis hjälper den dej.

Hittade den några problem och åtgärdade?

 

Ett annat tips jag vet kan hjälpa är att radera ALLA filerna som ligger i mappen c:\windows\system32\spool\printers

Starta om datorn. Hämta hem nya drivrutiner till skrivaren och starta om datorn igen. Anslut skrivaren och starta om datorn igen. Fungerar det nu?

Anmäl
2011-10-15 21:53 #12 av: Isa56

Hej, tack för ditt svar. Tyvärr fungerar det inte.

Fix-it har jag kört tidigare, körde det igen. Den har åtgärdat några fel, Men ett fel kan den inte åtgärda och det är att skrivartjänsten är stoppad och den kan den inte starta.

Alla filer i mappen "printers" är raderade. Nya drivrutiner hämtade från Canons hemsida, scannern blev installerad men skrivarens drivrutiner går inte att installera för "spoolern" är stoppad.

Jag har startat om datorn och försökt installera skrivaren med noll resultat. Jag har även försökt reparera spoolern med hjälp av säkerhetskopian, får "felkod".

De som jag tycker är lite konstigt är att när jag försöker öppna spoolern i "sys32" så bara blinkar fönstret till och försvinner, den går inte att öppna.

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-10-16 13:29 #13 av: Micro08

 

 

Tror att något har blivit fel redan från allra första början eftersom skrivaren är en Plug-and-Play och man ska därför inte manuellt lägga till den.

Något har blivit "dubbelt" mellan den gamla och nya. (tänker högt)

Hm!

Här är annars helt tar bort skrivardrivrutiner från Windows och kan börja om från början, på rätt sätt.

Antar att du fick med en CD-skiva till den?

 

 

 

 

 

Anmäl
2011-10-16 16:43 #14 av: Isa56

Jadå skiva till skrivaren har jag, har också en nerladdad fil på drivrutin (från Canons hemsida) på skrivbordet.

Ska prova länken och se vad som händer. Det kan ju knappast bli sämreFlört.

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-10-16 17:51 #15 av: Isa56

Nej, hjälpte inte heller. Jag har ingen "utskriftshantering" i den här MMC.

Felet uppstod när jag avinstallerade Lexmarken. Den stoppade spoolern, och spoolern försvann från mappen "Tjänster". Spoolern kan heller inte öppnas i "sys32" mappen.

Jag har provat att återställa med säkerhetskopia från D-disken, går inte får felkod.

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-10-16 18:02 #16 av: Micro08

 

 

Har nog bara ett sista förslag då, som jag hittade på något forum någonstans :

 

Some Lexmark printer drivers install a service called LexBCES, and make the spooler dependent on that service. There seem to be a number of cases where the LexBCES service gets hung, and that then blocks the spooler from starting. To fix this:

1. open a Command Prompt window (Go to "start" "all programs" "accessories" "command prompt"

2. key in the following:
sc config spooler depend= RPCSS
(note there is no space between the depend & the = but there is a space after the = before the RPCSS)

3. press Enter.
This will probably leave the Lexmark printer non-functional but at least allow printing to other printers.

 

 

Anmäl
2011-10-16 18:25 #17 av: Isa56

Den tjänsten (LexBCES) var inte installerad. Tydligen har jag nog fått bort den tidgare.

Nu har det blivit en liten utmaning att försöka få igång den.Flört

Funderar, spools.exe har sökväg till sys32, men där är en fil till som heter spools.DLL och den har sökväg till skrivbordet???? Kan det vara något där som blockerar?

 

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-10-16 19:56 #18 av: Micro08

 

Vad har du att förlora på att ta bort den och sedan återinstallera? Jag skulle göra det.

Det här fann jag om spoolss.dll

Det går sedan att hämta hem filen här.

Du kan ju också testa att stänga av processen spoolss.exe tillfälligt genom ctrl+alt+del och se om det då går att installera Canon.

I mitt register finns spoolss.dll under följande men inga sökvägar är till skrivbordet.

C:\i386, C:\WINDOWS\system32 och C:\WINDOWS\ServicePackFiles\i386

 

Anmäl
2011-10-16 20:13 #19 av: Isa56

Tack, där har jag lite att prova.

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2011-10-25 18:17 #20 av: Isa56

Fortfarande inget liv i spoolern.

Stänga av processen går inte, för processen finns inte, i varken tjänster eller aktivitetshanteran. Så tyvärr fick jag inte igång den med den hjälpen heller. (Böjar undra om jag är envis eller bara tjurskallig)Flört

Däremot funderade jag på hur mstor skillnad där är på den i Vista kontra Xp?  För, minneskortet la av på min gamla dator. Så jag plockade ut hårddisken och köpte ett kabinett till den. Jag har tänkt lägga in bilder och musik på den. Nu har jag inte formaterat den så Xp ligger kvar. Frågan är kan jag koppla in den och på något sätt använda spoolern i den för att få igång utskrifttjänsten? Lite luddigt fråga kanske, men hoppas ni förstår hur jag menar.

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2012-01-05 00:41 #21 av: Isa56

Nu har jag fått igång min Print spooler. Tungan ute Jag är nog rätt tålmodig.Oskyldig Fick tips om att köra combofix och ett program som heter TFC. Defixade till mina fel i datorn och efter omstart så susade drivrutinerna till skrivaren rätt in, och nu fungerar det.

Kände att jag ville berätta. Nu sparar jag pengarna för win7 som jag var på väg att köpa.

Tack för hjälpen härinne. Jag lärde mig en hel del av det också. Skrattande

 

"Om du inte gillar något, ändra det. Om du inte kan ändra det, ändra din attityd. Beklaga dig inte. " Maya Angelou"                                                                 

Anmäl
2013-08-08 18:15 #22 av: Kinne

Jag kör Ubuntu och har exakt samma problem. Vad ska JAG göra? ;/

Anmäl

Det finns en till kommentar till den här diskussionen. Den är bara synlig för medlemmar på iFokus. För att läsa kommentaren, logga in eller registrera dig på iFokus.